Your comments

Just to bump this again. I have the opposite problem. I frequently have a bunch of pinned tabs, sometimes in a folder, and with nesting - quite a tree of tabs. When I open Google Drive and open a document, it lands right in the middle of the tree (between the last pinned tab and next non-pinned tab). This behaviour makes no sense in this case, and I want all new tabs (whether via CTRL+T or a link from an existing tab to go to the bottom / right. I'm often opening a bunch of links from GDrive, and then can never find them...

I installed tabs2end to try and achieve this, but it doesn't play well with SW - on Chrome the tab moves to the right, but in SW it stays where it was, and no the 2 lists are out of sync.



Actually, I think it might be redirects in general - I've just had exactly the same thing happen on a website I'm working on (it's a Wordpress site), with a redirect on login page. The SW tab title stayed as 'Login', whereas the Chrome tab has redirected to the page on the site I was after.

Looks like it might be some conflict with how chrome processes redirects?

OK - it's getting pretty repeatable now. It happens when searching via the Chrome omnibox using google instant. As soon as I either go to the main google homepage and search from there, or turn off SW and search from the omnibox, everything is fine.

Another possible pattern - tenuous, as it could just be when it becomes obvious re CPU usage, but I'm noticing it whenever I'm typing into a google search box and have Google Instant active. Don't know if that could be triggering it somehow?

I'd say this is happening 2-3 times a day now on average. The quickest way to fix it I've found is to disable SW in Chrome settings, then enable it again - I keep the Extensions page open all the time now :)

I've also noticed that on re-enabling SW, I see a hibernated version of any tabs which I opened prior to the runaway, as well as the real 'live' tab which is open in Chrome. I presume this is just a side-effect, but wondered if it might help pin things down.

Please let me know if you need more info - it would be great to solve this one, as it's making SW a bit niggly to use, which is such a shame...

And of course, within minutes, it happened. I've sent the diagnostics, and it said it had succeeded. Hope it helps pin things down :)

No runaway yet, but the advantage of debug mode is that zombie tabs are really easy to sort out with 'reset tree' :). Perhaps that could be built in to non-debug mode using CTRL+R (similar to reload with no caching on a main chrome tab)?

Will do - only happened once today so far :| Might be a tricky one to catch

I now have 8 tabs open in Chrome (3 pinned, 5 normal), and SW is showing the 3 pinned (which work) and 1 normal (which is zombie)...

Any thoughts or other things I can test? I really haven't noticed a pattern yet, except that it normally starts with the last or next-to-last tab.